InTouch Machine Edition OI Server 1.2

Operations Integration Core 1.2 must be installed prior to installing this OI Server.

Supports InTouch Machine Edition up to version 8.0

Please ensure you are logged in - Downloading this file requires the user to be a customer of Industrial Software Solutions. If you are a customer, please contact us to ensure your account is properly registered.